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Servo drive application backup & restore with Gem Drive Studio 

 
 
 
 
 
 
 
 
 
 
 
1 – INTRODUCTION 
 
The GemDriveStudio PC software tool has been developed for the parameterization and commissioning of 
series XtrapulsPac servo drives. GemDriveStudio is a multi-axis software that allows the parameterization 
of  all  drives  in  a  same  application  via  one  single  connection  (serial  link  RS232).  This  application  note 
describes  the  following  basic  operations  for  a  given  application:  drive  configuration  backup  and  drive 
configuration restore. For more information about the software installation and the functionalities description, 
please refer to the GemDriveStudio quick start manual. 
 
 
2 – OFF-LINE PROJECT BUILDING 
 
A  project  consists  in  a  representation  of  the  application  with  all  drives  connected  to  the  CAN  bus.  The 
creation of the project off-line allows to enter the desired user name for each drive (Spindle, X rotation, Y 
advance,  ...) according to the application.  
 
For creating the project off-line according to a given application, proceed as described below: 
 

- Select first "New project" in the “File” menu, and follow the project creation instructions. 
 

- Select "Add a device" in the "Project" menu, and follow the device creation instructions. 
 

- Select "Remove a device" in the "Project" menu, in order to remove a drive from the project. 
 

- When all servo drives of the application have been defined, select “Save project” in the “File” menu. 
 

 
3 – APPLICATION BACKUP (concerns all drives of the project)  
 
If the application project has been previously created and saved, proceed as described below: 
 
      -  Select “Open project” in the “File” menu, and then select the application project.  
 
      -  Select "Connect to the fieldbus" in the “Connection” menu, for establishing the communication with  
             the servo drives. 
 

- Select  “Drive  files  backup”  in  the  “Tools”  menu,  and  then  “Backup  from  the  drives”.  All  drive 
configuration files (parameters, sequences, programs, ...) are saved in the drives and transferred into 
the project directory on the PC. A backup directory named “SDcard” is also created in the project 
directory. So, after this operation, the drive parameters and the project parameters on the PC 
are identical. 

 
- Select  “Archive  the  project”  in  the  “File”  menu.  Archiving  a  project  groups  all  files  of  the  project 

directory as well as the project structure in a ZIP file. It is convenient for transferring a project on 
another PC. 
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If the application project is not available, proceed as described below: 
 
      - Select "Scan the fieldbus to detect devices" in the “Connection” menu and follow the instructions.           
             The "Scan" function allows the automatic creation of a project with all drives connected to the  
             bus. 
 

- Select  “Drive  files  backup”  in  the  “Tools”  menu,  and  then  “Backup  from  the  drives”.  All  drive 
configuration files (parameters, sequences, programs, ...) are saved in the drives and transferred into 
the project directory on the PC. A backup directory named “SDcard” is also created in the project 
directory. So, after this operation, the drive parameters and the project parameters on the PC 
are identical. 

 
- Select “Save project” in the “File” menu and follow the project saving instructions. 
 
- Select  “Archive  the  project”  in  the  “File”  menu.  Archiving  a  project  groups  all  files  of  the  project 

directory as well as the project structure in a ZIP file. It is convenient for transferring a project on 
another PC. 

 
For saving different drive configurations of a same application, proceed as described below: 
 
      - Select first “Save project as” in the “File” menu and follow the project saving instructions. 
 
      - Modify the application parameters and settings. 
 
      - Then select the “Drive files backup” operation. 
 
Remark: The backup directory named “SDcard” created during the backup operation contains all files for an 
SDcard in order to restore drives which have an SDcard connector. Select “Drive files backup” in the “Tools” 
menu, and then ”Copy backup files to movable support” for this operation. However, the “SDcard” directory 
does not include the full project information. So, for a project to be transferred on another PC, it must be 
archived in a ZIP file. 
 
Note: In order to access the current project directory, select "Open the directory" in the "Project" menu. 
 
 
4 – APPLICATION RESTORE (concerns all drives of the project) 
 
If the application project has been previously archived in a ZIP file, proceed as described below: 
 
     - Select "Unarchive the project" in the "File" menu, then select the archive ZIP file according to the   

application and the output directory. The project is then unarchived and can be opened. The name of 
the project directory will be the same than the ZIP file. 
 

- Select "Connect to the fieldbus" in the “Connection” menu, for establishing the communication with 
the servo drives. 

 
     - Select “Drive files restore” in the “Tools” menu, and then “Restore all the application”.  
 

- Select  the  backup  directory  named  “SDcard”  in  the  project  directory.  All  drive  configuration  files 
(parameters, sequences, programs, ...) saved in the backup directory are transferred in the 
application servo drives and in the current project directory on the PC. So, after this action, the 
drive parameters and the project parameters on the PC are identical. 

 
Remark 1: For restoring various drive configurations of a same application, open the corresponding project, 
then  execute  the  “Drive  files  restore”  command,  and  select  the  backup  directory  named  “SDcard”  in  the 
project directory. 
 
Remark 2: For restoring only one drive of a given application, select “Drive files restore” in the “Tools” menu, 
and then “Restore only 1 device”. Then, follow the restore command instructions. 
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If the application project archive (ZIP file) is not available, but only the “SDcard” backup directory, proceed as 
described below: 
 

- Select "Scan the fieldbus to detect devices" in the “Connection” menu and follow the instructions. 
The "Scan" function allows the automatic creation of a project with all the drives connected to the 
bus. 

 
- Select “Save project” in the “File” menu and follow the project saving instructions. 
 
- Select “Drive files restore” in the “Tools” menu, and then “Restore all the application”.  
 
- Select  the  backup  directory  named  “SDcard”  in  the  project  directory.  All  drive  configuration  files 

(parameters,  sequences,  programs,  ...)  saved  in  the  backup  directory  are  transferred  into  the 
application servo drives and into the current project directory on the PC. So, after this operation, 
the drive parameters and the project parameters on the PC are identical. 

 
Note: In order to access the current project directory, select "Open the directory" in the "Project" menu. 
 
 
5 – DRIVE PARAMETERS BACKUP (concerns one project drive) 
 
Connect first the concerned drive in the project treeview, and then proceed as described below: 
 

- Select “Parameter setting” and “Drive parameters file” in the treeview. 
 

- Execute “Backup parameters to PC file” in the “Drive parameters file” window. The drive parameters 
are saved in the DRIVEPAR.TXT file in the drive; this file is then transferred in the project directory 
on  the  PC  and  placed  in  the  appropriate  sub  directory  with  the  device  name.  So,  after  this 
operation,  the  drive  parameter  values  and  the  DRIVEPAR.TXT  file  parameter  values  in  the 
project directory on the PC are identical. 

 
 
6 – DRIVE PARAMETERS RESTORE (concerns one project drive) 
 
Connect first the concerned drive in the project treeview, proceed then as described below: 
 
        - Select “Parameter setting” and “Drive parameters file” in the treeview. 
 
        - Execute “Restore parameters” in the “Drive parameters file” window.  
 

- Select the required backup file (DRIVEPAR.TXT type) on the PC directory. The selected backup file 
is first copied into the current project directory on the PC (in the appropriate sub directory with the 
device name) and renamed DRIVEPAR.TXT if its name was different. It is then transferred into the 
servo drive, and the current drive parameter values are overwritten. So, after this operation, the 
drive parameter values and the DRIVEPAR.TXT file parameter values in the project directory 
on the PC are identical. 

 
 
7 – FILE SERVICE TOOL 
 
Select “File service” in the “Tools” menu. The concerned drive can be selected in the “Axis” list. 
 
The command “Write a file into the drive” allows to send a drive configuration file (parameters, sequences,..) 
from the PC to the drive. Only the drive specific files with a reserved name can be sent (DRIVEPAR.TXT, 
USER_PAR.TXT,  SEQUENCE.TXT,  ...).  After  the  file  transfer,  the  drive current  parameter  values  are not 
overwritten. The new file parameter values will be considered only at the next drive power up. 
 
The command “Write an object file into the drive” allows to send the parameter values in the selected file into 
the drive. Any drive parameter file, regardless from its name, can be sent. However, the parameter syntax in  
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the  file  must  be  observed.  After  the  file  parameter  transfer,  the  drive  parameter  values  are  overwritten. 
However, these parameter values are not saved in the drive. 
The “File service” is reserved to skilled people, because an incorrect use may involve a wrong operation of 
the drive. In this case, do not make any backup operation in order to avoid the PC files being corrupted as 
well. Proceed as described below in order to restore the correct drive configuration: 
 
       - Delete all drive files by using the “Delete” command”. 
 

- Switch off and on again the drive logic supply (24 V). At power up, the drive default parameter values 
(from the firmware) will be considered. 

 
- Restore the correct drive configuration by using the “Drive files restore” function or the “Parameter 

file restore” function. If a safe backup had not been made before, the commissioning procedure must 
be renewed. 

 
 
8 – OFF-LINE PARAMETER DISPLAY AND OPERATIONS 
 
If the application project has been previously created and saved, proceed as described below: 
 
       - Select “Open project” in the “File” menu, and then select the application project.  
 

- Right-click  on  the  node  of  the  project  tree  and  select  "Simulate".  Renew  the  operation  for  all  the 
desired application servo drives. 

 
If the application project has been previously archived in a ZIP file, proceed as described below: 
 

- Select "Unarchive the project" in the "File" menu, then select the archive ZIP file according to the 
application and the output directory. The project is then unarchived and can be opened. 

 
- Right-click  on  the  node  of  the  project  tree  and  select  "Simulate".  Renew  the  operation  for  all  the 

desired application servo drives. 
 
The drive simulation allows the following operations:  
 

- display of the parameter file saved in the project drive directory,  
 

- display, modification and saving of the sequence files saved in the project drive directory, 
 

- display, modification, compilation and saving of the programming source files saved in the project 
drive directory. 

 
A backup operation can be achieved off-line as described below: 
 

- Select “Drive files backup” in the “Tools” menu, and then “Backup from the project directory”. All the 
project  directory  configuration  files  (parameters,  sequences,  programs,  ...)  are  saved  in  a  backup 
directory named “SDcard” in the project directory. 

 
- The backup directory named “SDcard” created during this backup operation contains all files for an 

SDcard in order to restore drives which have an SDcard connector. Select “Drive files backup” in the 
“Tools” menu, and then ”Copy backup files to movable support” for this operation. 
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